]> git.t-rg.ws Git - slackbuilds.git/commitdiff
Added rejoystick, because the original SlackBuild's maintainer at SBo dropped it...
authorfsLeg <fsleg@t-rg.ws>
Wed, 12 Nov 2014 23:33:03 +0000 (02:33 +0300)
committerfsLeg <fsleg@t-rg.ws>
Wed, 12 Nov 2014 23:33:03 +0000 (02:33 +0300)
rejoystick/README [new file with mode: 0644]
rejoystick/memory.patch [new file with mode: 0644]
rejoystick/rejoystick.SlackBuild [new file with mode: 0755]
rejoystick/rejoystick.info [new file with mode: 0644]
rejoystick/slack-desc [new file with mode: 0644]

diff --git a/rejoystick/README b/rejoystick/README
new file mode 100644 (file)
index 0000000..1a58bee
--- /dev/null
@@ -0,0 +1,5 @@
+Rejoystick is a program that maps keypresses on your
+gamepad/joypad/joystick to keypresses on a keyboard when you
+are running X. Since it uses SDL to communicate with the gamepad
+device, it can work on every platform that provides SDL and an
+X environment. (Though it is yet to be tested on Cygwin e.g.)
diff --git a/rejoystick/memory.patch b/rejoystick/memory.patch
new file mode 100644 (file)
index 0000000..3212626
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/src/main.c       2008-03-23 17:38:22.000000000 +0300
++++ b/src/main.c       2014-06-29 21:15:36.000000000 +0400
+@@ -137,12 +137,9 @@
+       pthread_t       sdl_thread;
+-      char*           home;
+-      char*           keyfile;
+-
+-      home = (char*)getenv("HOME");
+-      keyfile = KEYFILE;
+-      filename = strcat(home, keyfile);
++      const char * home = getenv("HOME");
++      filename = malloc(strlen(home) + strlen(KEYFILE) + 1);
++      sprintf(filename, "%s%s", home, KEYFILE);
+       global_argv = argv;
diff --git a/rejoystick/rejoystick.SlackBuild b/rejoystick/rejoystick.SlackBuild
new file mode 100755 (executable)
index 0000000..8379d34
--- /dev/null
@@ -0,0 +1,111 @@
+#!/bin/sh
+
+# Slackware build script for rejoystick
+
+# Originally written by Steven Pledger <linux.propane@yahoo.com>
+# Modified 2014 Vladislav Borisov, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
+#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=rejoystick
+VERSION=${VERSION:-0.8.1}
+BUILD=${BUILD:-2}
+TAG=${TAG:-fsleg}
+
+# Use parallel building if possible
+if [ -z "$NUMJOBS" ]; then
+  NUMJOBS=$(nproc)
+fi
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i486 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+else
+  SLKCFLAGS="-O2"
+  LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Specify the path to the version.mk file inside of the configure script
+sed -i "s|^\.\ version\.mk|. ./version.mk|" configure
+
+# Fix memory issue
+patch -p1 < ${CWD}/memory.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+  --prefix=/usr \
+  --libdir=/usr/lib${LIBDIRSUFFIX} \
+  --sysconfdir=/etc \
+  --localstatedir=/var \
+  --disable-static \
+  --build=$ARCH-slackware-linux
+
+make -j${NUMJOBS}
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# AUTHORS, ChangeLog, and NEWS are empty files
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+  COPYING INSTALL README \
+  $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/rejoystick/rejoystick.info b/rejoystick/rejoystick.info
new file mode 100644 (file)
index 0000000..52c878c
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="rejoystick"
+VERSION="0.8.1"
+HOMEPAGE="http://rejoystick.sourceforge.net/"
+DOWNLOAD="http://sourceforge.net/projects/rejoystick/files/rejoystick/rejoystick-0.8.1/rejoystick-0.8.1.tar.gz"
+MD5SUM="43208b766a131e2725bfd72caf60a41d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Vladislav Borisov"
+EMAIL="fsleg@t-rg.ws"
diff --git a/rejoystick/slack-desc b/rejoystick/slack-desc
new file mode 100644 (file)
index 0000000..674fdf7
--- /dev/null
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+          |-----handy-ruler------------------------------------------------------|
+rejoystick: rejoystick (translates joystick keypresses to keyboard)
+rejoystick:
+rejoystick: Rejoystick is a program that maps keypresses on your
+rejoystick: gamepad/joypad/joystick to keypresses on a keyboard when you
+rejoystick: are running X. Since it uses SDL to communicate with the gamepad
+rejoystick: device, it can work on every platform that provides SDL and an
+rejoystick: X environment. (Though it is yet to be tested on Cygwin e.g.)
+rejoystick:
+rejoystick: Homepage: http://rejoystick.sourceforge.net/
+rejoystick:
+rejoystick: