]> git.t-rg.ws Git - slackbuilds.git/commitdiff
gxkb: added
authorfsLeg <fsleg@t-rg.ws>
Sat, 13 Jul 2024 19:00:49 +0000 (22:00 +0300)
committerfsLeg <fsleg@t-rg.ws>
Sat, 13 Jul 2024 19:00:49 +0000 (22:00 +0300)
gxkb/README [new file with mode: 0755]
gxkb/by-ru-flags.patch [new file with mode: 0755]
gxkb/by.png [new file with mode: 0755]
gxkb/gxkb.SlackBuild [new file with mode: 0755]
gxkb/gxkb.info [new file with mode: 0755]
gxkb/ru.png [new file with mode: 0755]
gxkb/slack-desc [new file with mode: 0755]

diff --git a/gxkb/README b/gxkb/README
new file mode 100755 (executable)
index 0000000..4c698ab
--- /dev/null
@@ -0,0 +1 @@
+X11 keyboard indicator and switcher
diff --git a/gxkb/by-ru-flags.patch b/gxkb/by-ru-flags.patch
new file mode 100755 (executable)
index 0000000..d9c3854
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/data/flags/Makefile.am   2024-07-13 12:33:45.000000000 +0300
++++ b/data/flags/Makefile.am   2024-07-13 12:35:10.684982352 +0300
+@@ -13,6 +13,7 @@
+     br.png           \
+     bt.png           \
+     bw.png           \
++    by.png           \
+     ca.png           \
+     cd.png           \
+     ch.png           \
+@@ -78,6 +79,7 @@
+     pt.png           \
+     ro.png           \
+     rs.png           \
++    ru.png           \
+     se.png           \
+     si.png           \
+     sk.png           \
diff --git a/gxkb/by.png b/gxkb/by.png
new file mode 100755 (executable)
index 0000000..395470e
Binary files /dev/null and b/gxkb/by.png differ
diff --git a/gxkb/gxkb.SlackBuild b/gxkb/gxkb.SlackBuild
new file mode 100755 (executable)
index 0000000..843fa71
--- /dev/null
@@ -0,0 +1,122 @@
+#!/bin/bash
+
+# Slackware build script for gxkb
+
+# Copyright 2015-21 NK
+# Copyright 2024 Vladislav Borisov Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
+#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=gxkb
+VERSION=${VERSION:-0.9.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-fsleg}
+PKGTYPE=${PKGTYPE:-txz}
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i586 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+  exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+else
+  SLKCFLAGS="-O2"
+  LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+  -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+  
+# Patch back Belorussian and Russian flags
+patch -p1 < $CWD/by-ru-flags.patch
+cp $CWD/{by,ru}.png data/flags/
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./autogen.sh
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+  --prefix=/usr \
+  --libdir=/usr/lib${LIBDIRSUFFIX} \
+  --sysconfdir=/etc \
+  --localstatedir=/var \
+  --mandir=/usr/man \
+  --docdir=/usr/doc/$PRGNAM-$VERSION \
+  --build=$ARCH-slackware-linux \
+  --enable-appindicator=no
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION/
+install -Dm 644 $CWD/$PRGNAM.SlackBuild $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gxkb/gxkb.info b/gxkb/gxkb.info
new file mode 100755 (executable)
index 0000000..6e694f2
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="gxkb"
+VERSION="0.9.5"
+HOMEPAGE="https://zen-tools.github.io/gxkb/"
+DOWNLOAD="https://github.com/zen-tools/gxkb/archive/v0.9.5/gxkb-0.9.5.tar.gz"
+MD5SUM="597a1c052156a878aa252fca10c985c6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Vladislav Borisov"
+EMAIL="fsleg@t-rg.ws"
diff --git a/gxkb/ru.png b/gxkb/ru.png
new file mode 100755 (executable)
index 0000000..cbe942b
Binary files /dev/null and b/gxkb/ru.png differ
diff --git a/gxkb/slack-desc b/gxkb/slack-desc
new file mode 100755 (executable)
index 0000000..781b1a1
--- /dev/null
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+    |-----handy-ruler------------------------------------------------------|
+gxkb: gxkb (X11 keyboard indicator and switcher)
+gxkb:
+gxkb: gxkb is a little indicator applet which allows one to quickly switch
+gxkb: between different keyboard layouts in X. A flag corresponding to the 
+gxkb: country of the active layout is shown in the indicator area.
+gxkb:
+gxkb: The applet is written in C and uses the GTK+ library and therefore
+gxkb: does not depend on any GNOME components.
+gxkb:
+gxkb: Homepage: https://zen-tools.github.io/gxkb
+gxkb: