]> git.t-rg.ws Git - slackbuilds.git/commitdiff
fdpowermon: added
authorfsLeg <fsleg@t-rg.ws>
Sat, 14 Oct 2023 14:41:23 +0000 (17:41 +0300)
committerfsLeg <fsleg@t-rg.ws>
Sat, 14 Oct 2023 14:41:23 +0000 (17:41 +0300)
fdpowermon/README [new file with mode: 0644]
fdpowermon/fdpowermon.SlackBuild [new file with mode: 0755]
fdpowermon/fdpowermon.info [new file with mode: 0644]
fdpowermon/slack-desc [new file with mode: 0644]

diff --git a/fdpowermon/README b/fdpowermon/README
new file mode 100644 (file)
index 0000000..ba45a0e
--- /dev/null
@@ -0,0 +1,17 @@
+fdpowermon is a simple perl script that installs an icon in a system
+tray compatible with the freedesktop.org specification.
+
+Every three seconds, fdpowermon calls acpi to find out what the current
+battery level is. It will set the output of the acpi command as a
+tooltip text, and will update the used icon as appropriate.
+
+In addition, fdpowermon can optionally call perl subroutines when the
+power reaches a given level. No such subroutines are provided or
+enabled by default, however.
+
+Features:
+- minimalist. The code consists of a good 500 lines, most of which are
+  documentation and comments.
+- A power monitor, not a power manager.
+- The ability (not enabled by default) to suspend a laptop on low power
+  levels, or do other tasks when the battery reaches a particular level.
diff --git a/fdpowermon/fdpowermon.SlackBuild b/fdpowermon/fdpowermon.SlackBuild
new file mode 100755 (executable)
index 0000000..d63ee62
--- /dev/null
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+# Slackware build script for dart-sass
+
+# Copyright 2022 Vladislav Borisov Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
+#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM="fdpowermon"
+VERSION=${VERSION:-1.20}
+BUILD=${BUILD:-1}
+TAG=${TAG:-fsleg}
+TARNAM=$PRGNAM-$PRGNAM-$VERSION
+
+# It's a Perl script, so arch doesn't matter
+ARCH="noarch"
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# This is just a repackaging of a script, no compilation is needed
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+
+tar xvf $CWD/$TARNAM.tar.gz
+cd $TARNAM
+mkdir -p $PKG/usr/bin $PKG/etc/$PRGNAM $PKG/usr/share/icons/oxygen/base/22x22/status
+cp fdpowermon $PKG/usr/bin/
+cp theme.cfg $PKG/etc/$PRGNAM/
+cp icons/*.png $PKG/usr/share/icons/oxygen/base/22x22/status/
+chown -R root:root $PKG
+find -L $PKG \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+  -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Copy program documentation and the SlackBuild into the package
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/examples
+cp -a debian/copyright debian/changelog README.md $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a theme.pl $PKG/usr/doc/$PRGNAM-$VERSION/examples/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Create and package the man page
+mkdir -p $PKG/usr/man/man1
+/usr/bin/pod2man < fdpowermon | gzip -9 -c > $PKG/usr/man/man1/fdpowermon.1.gz
+
+
+# Copy the slack-desc into ./install
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
diff --git a/fdpowermon/fdpowermon.info b/fdpowermon/fdpowermon.info
new file mode 100644 (file)
index 0000000..84f1cd5
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="fdpowermon"
+VERSION="1.20"
+HOMEPAGE="https://github.com/yoe/fdpowermon"
+DOWNLOAD="https://github.com/yoe/fdpowermon/archive/refs/tags/fdpowermon-1.20.tar.gz"
+MD5SUM="9e1fcebcdc655e66bc0310ca40a7572b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="acpi perl-Gtk3"
+MAINTAINER="Vladislav Borisov"
+EMAIL="fsleg@t-rg.ws"
\ No newline at end of file
diff --git a/fdpowermon/slack-desc b/fdpowermon/slack-desc
new file mode 100644 (file)
index 0000000..caa7893
--- /dev/null
@@ -0,0 +1,12 @@
+          |-----handy-ruler------------------------------------------------------|
+fdpowermon: fdpowermon (simple battery power monitor for laptops with ACPI)
+fdpowermon:
+fdpowermon: fdpowermon is a simple perl script that installs an icon in a system
+fdpowermon: tray compatible with the freedesktop.org specification.
+fdpowermon:
+fdpowermon: Every three seconds, fdpowermon calls acpi to find out what the current
+fdpowermon: battery level is. It will set the output of the acpi command as a
+fdpowermon: tooltip text, and will update the used icon as appropriate.
+fdpowermon:
+fdpowermon: Homepage: https://github.com/yoe/fdpowermon
+fdpowermon: