]> git.t-rg.ws Git - slackbuilds.git/commitdiff
Further cleanups
authorfsLeg <fsleg@t-rg.ws>
Sun, 14 Jul 2024 16:45:34 +0000 (19:45 +0300)
committerfsLeg <fsleg@t-rg.ws>
Sun, 14 Jul 2024 16:45:34 +0000 (19:45 +0300)
30 files changed:
dart-sass/dart-sass.SlackBuild
dart-sass/slack-desc
dumptorrent/dumptorrent.SlackBuild
dumptorrent/slack-desc
fdpowermon/fdpowermon.SlackBuild
fdpowermon/slack-desc
gxkb/README [changed mode: 0755->0644]
gxkb/by-ru-flags.patch [changed mode: 0755->0644]
gxkb/by.png [changed mode: 0755->0644]
gxkb/gxkb.info [changed mode: 0755->0644]
gxkb/ru.png [changed mode: 0755->0644]
gxkb/slack-desc [changed mode: 0755->0644]
pyotherside/pyotherside.SlackBuild
pyotherside/slack-desc
pyscard/pyscard.SlackBuild
pyscard/slack-desc
python-fido2/python-fido2.SlackBuild
python-fido2/slack-desc
saflashplayer/README
saflashplayer/saflashplayer.SlackBuild
saflashplayer/saflashplayer.sh [deleted file]
saflashplayer/slack-desc
shadowsocks-rust/shadowsocks-rust.SlackBuild
shadowsocks-rust/slack-desc
yubikey-manager-qt/slack-desc
yubikey-manager-qt/yubikey-manager-qt.SlackBuild
yubikey-manager/slack-desc
yubikey-manager/yubikey-manager.SlackBuild
yubioath-desktop/slack-desc
yubioath-desktop/yubioath-desktop.SlackBuild

index 3690023f9ae576f66160960aa33f2cc81c4f9b60..e3d461c401ae14462844bd18a69de12a0b90b59e 100755 (executable)
@@ -30,12 +30,10 @@ BUILD=${BUILD:-1}
 TAG=${TAG:-fsleg}
 PKGTYPE=${PKGTYPE:-txz}
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
     i?86) ARCH="ia32" ;;
     x86_64*) ARCH="x64" ;;
-    # Unless $ARCH is already set, use uname -m for all other archs:
        *) ARCH=$( uname -m ) ;;
   esac
 fi
@@ -60,7 +58,7 @@ fi
 
 # This is just a repackaging of a pre-built binary, no compilation is needed
 
-set -e # Exit on most errors
+set -e
 
 rm -rf $PKG
 mkdir -p $TMP $PKG $OUTPUT
@@ -86,9 +84,8 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
 cp -a src/LICENSE $PKG/usr/doc/$PRGNAM-$VERSION/
 cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
 
-# Copy the slack-desc (and a custom doinst.sh if necessary) into ./install
 mkdir -p $PKG/install
 cat $CWD/slack-desc > $PKG/install/slack-desc
 
 cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
index 4f9cf5bd960e97410a48009588c5bfb99dc18182..59beac780afa8a0f7e9cfbbc5b0f4e78c5f88f2d 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
          |-----handy-ruler------------------------------------------------------|
 dart-sass: dart-sass (A Dart implementation of Sass)
 dart-sass:
@@ -9,3 +16,4 @@ dart-sass:
 dart-sass:
 dart-sass:
 dart-sass:
+dart-sass:
index 68e81133cfb720b62a04cf0fa8c5a53000e35e5b..51b6bcebd81d9c864e8d3193c840b483bf18db2b 100755 (executable)
@@ -35,12 +35,10 @@ if [ -z "$NUMJOBS" ]; then
   NUMJOBS=$(nproc)
 fi
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
-    i?86) ARCH=i486 ;;
+    i?86) ARCH=i586 ;;
     arm*) ARCH=arm ;;
-    # Unless $ARCH is already set, use uname -m for all other archs:
        *) ARCH=$( uname -m ) ;;
   esac
 fi
@@ -57,8 +55,8 @@ TMP=${TMP:-/tmp/SBo}
 PKG=$TMP/package-$PRGNAM
 OUTPUT=${OUTPUT:-/tmp}
 
-if [ "$ARCH" = "i486" ]; then
-  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
 elif [ "$ARCH" = "i686" ]; then
   SLKCFLAGS="-O2 -march=i686 -mtune=i686"
 elif [ "$ARCH" = "x86_64" ]; then
@@ -67,7 +65,7 @@ else
   SLKCFLAGS="-O2"
 fi
 
-set -e # Exit on most errors
+set -e
 
 rm -rf $PKG
 mkdir -p $TMP $PKG $OUTPUT
@@ -82,7 +80,7 @@ find -L . \
  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
 
-make -j${NUMJOBS} dumptorrent CFLAGS="${SLKFLAGS}"
+make -j${NUMJOBS} dumptorrent CFLAGS="${SLKCFLAGS}"
 
 # There's no 'install' target and no documentation, so we just copy the binary
 # to a correct location and package it.
@@ -94,7 +92,6 @@ install -Dm755 ./dumptorrent ${PKG}/usr/bin/
 find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
   | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
 
-# Copy the SlackBuild into the package
 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
 cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
 
@@ -104,4 +101,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
 
 # Make the package
 cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
index e775196387452b97099056a42c13c87342e73261..72f2e51b4796d63b3aeab42f26d4efe93847d88d 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
            |-----handy-ruler------------------------------------------------------|
 dumptorrent: dumptorrent (get torrent metadata)
 dumptorrent:
@@ -9,3 +16,4 @@ dumptorrent:
 dumptorrent: Website: http://sourceforge.net/projects/dumptorrent/
 dumptorrent:
 dumptorrent:
+dumptorrent:
index 4d26a36a9de90726d31f3c9b40a49707434997aa..2eddc3e16b7f89d10f9b5531cd1ff30332d72d8c 100755 (executable)
@@ -47,7 +47,7 @@ OUTPUT=${OUTPUT:-/tmp}
 
 # This is just a repackaging of a script, no compilation is needed
 
-set -e # Exit on most errors
+set -e
 
 rm -rf $PKG
 mkdir -p $TMP $PKG $OUTPUT
@@ -82,4 +82,4 @@ mkdir -p $PKG/install
 cat $CWD/slack-desc > $PKG/install/slack-desc
 
 cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
index caa7893ceb788f28ff75948660899f7b95dab6cf..00619d2e1f17f41c6643457c987ad46946b98306 100644 (file)
@@ -1,12 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
           |-----handy-ruler------------------------------------------------------|
 fdpowermon: fdpowermon (simple battery power monitor for laptops with ACPI)
 fdpowermon:
 fdpowermon: fdpowermon is a simple perl script that installs an icon in a system
 fdpowermon: tray compatible with the freedesktop.org specification.
 fdpowermon:
-fdpowermon: Every three seconds, fdpowermon calls acpi to find out what the current
-fdpowermon: battery level is. It will set the output of the acpi command as a
-fdpowermon: tooltip text, and will update the used icon as appropriate.
+fdpowermon: Every three seconds, fdpowermon calls acpi to find out what the
+fdpowermon: current battery level is. It will set the output of the acpi command
+fdpowermon: as a tooltip text, and will update the used icon as appropriate.
 fdpowermon:
 fdpowermon: Homepage: https://github.com/yoe/fdpowermon
 fdpowermon:
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
index c4cfffd741be32b8fd1dbacdd99044f5d395074e..a9310dc2b2d20f76d28f2097acb5bc925b666707 100755 (executable)
@@ -35,12 +35,10 @@ if [ -z "$NUMJOBS" ]; then
   NUMJOBS=$(nproc)
 fi
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
     i?86) ARCH=i586 ;;
     arm*) ARCH=arm ;;
-    # Unless $ARCH is already set, use uname -m for all other archs:
        *) ARCH=$( uname -m ) ;;
   esac
 fi
@@ -59,22 +57,17 @@ OUTPUT=${OUTPUT:-/tmp}
 
 if [ "$ARCH" = "i586" ]; then
   SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-  LIBDIRSUFFIX=""
 elif [ "$ARCH" = "i686" ]; then
   SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-  LIBDIRSUFFIX=""
 elif [ "$ARCH" = "x86_64" ]; then
   SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
 elif [ "$ARCH" = "aarch64" ]; then
   SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
 else
   SLKCFLAGS="-O2"
-  LIBDIRSUFFIX=""
 fi
 
-set -e # Exit on most errors
+set -e
 
 rm -rf $PKG
 mkdir -p $TMP $PKG $OUTPUT
@@ -89,8 +82,6 @@ find -L . \
  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
 
-
-# Compile the application and install it into the $PKG directory
 qmake
 CFLAGS="$SLKCFLAGS" \
 CXXFLAGS="$SLKCFLAGS" \
@@ -102,8 +93,6 @@ rm -rf $PKG/usr/tests
 find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
   | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
 
-# Copy program documentation into the package
-# Also, include the SlackBuild script in the documentation directory
 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
 
 # Build additional documentation
index 38050ab17197265492c883f40ddfbd2d93207160..e5bc9f35bc9531ab05a51ce2ff07172f4873d980 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
            |-----handy-ruler------------------------------------------------------|
 pyotherside: pyotherside (Python bindings for Qt)
 pyotherside:
index c7f0e44859ca81a637650b8635dd060d54ecf54b..2ee31cb2585a689100a5ec5ee8d68e2ced971487 100755 (executable)
@@ -30,12 +30,10 @@ BUILD=${BUILD:-1}
 TAG=${TAG:-fsleg}
 PKGTYPE=${PKGTYPE:-txz}
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
     i?86) ARCH=i586 ;;
     arm*) ARCH=arm ;;
-# Unless $ARCH is already set, use uname -m for all other archs:
        *) ARCH=$( uname -m ) ;;
   esac
 fi
@@ -52,23 +50,6 @@ TMP=${TMP:-/tmp/SBo}
 PKG=$TMP/package-$PRGNAM
 OUTPUT=${OUTPUT:-/tmp}
 
-if [ "$ARCH" = "i586" ]; then
-  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
-  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
-  SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "aarch64" ]; then
-  SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
-else
-  SLKCFLAGS="-O2"
-  LIBDIRSUFFIX=""
-fi
-
 set -e
 
 rm -rf $PKG
@@ -90,7 +71,6 @@ python3 setup.py install --root=$PKG
 find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
   | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
 
-# Copy program documentation into the package
 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
 
 # Build additional documentation
index d79d44a204c5742f7a17a87f7b3169653c05b724..9cc318e3e5acc9cc989aeb61f7ecefc495cd5d62 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
        |-----handy-ruler------------------------------------------------------|
 pyscard: pyscard (Smartcard module for Python)
 pyscard:
index 657b4ad99484930043f481c5832a0c3454bab7fe..6d50102dc11b9ab373e9a5dd8df333e48f9e12ae 100755 (executable)
@@ -31,12 +31,10 @@ BUILD=${BUILD:-1}
 TAG=${TAG:-fsleg}
 PKGTYPE=${PKGTYPE:-txz}
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
     i?86) ARCH=i586 ;;
     arm*) ARCH=arm ;;
-# Unless $ARCH is already set, use uname -m for all other archs:
        *) ARCH=$( uname -m ) ;;
   esac
 fi
@@ -53,23 +51,6 @@ TMP=${TMP:-/tmp/SBo}
 PKG=$TMP/package-$PRGNAM
 OUTPUT=${OUTPUT:-/tmp}
 
-if [ "$ARCH" = "i586" ]; then
-  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
-  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
-  SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "aarch64" ]; then
-  SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
-else
-  SLKCFLAGS="-O2"
-  LIBDIRSUFFIX=""
-fi
-
 set -e
 
 rm -rf $PKG
@@ -92,8 +73,6 @@ python3 -m installer --destdir "$PKG" dist/*.whl
 find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
   | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
 
-# Copy program documentation into the package
-# Also, include the SlackBuild script in the documentation directory
 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
 cp -aR \
   COPYING COPYING.MPLv2 COPYING.APLv2 NEWS README.adoc examples/\
index 221baa16136e1706bae5017b5c30dc9f89fda69d..c72cc2913195b5b073b3b1239138bf0eecb9faad 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
             |-----handy-ruler------------------------------------------------------|
 python-fido2: python-fido2 (FIDO2/WebAuthn library for clients and servers)
 python-fido2:
index dd5eb5c05e5574a4b04671f473182906df180831..53f27f1dd1de25c3dae0edefb84ca2e883e4f30a 100644 (file)
@@ -1,7 +1,4 @@
 Also known as Flash Player projector, SAFlashPlayer can play local SWF
 files without using web browser with Adobe plugin.
 
-Only 64bit binary is provided by Adobe.
-
-Checksum in .info file is unreliable, because Adobe updates the tarball
-without changing the link. This is also true for the program version.
+Only 64 bit binary is provided by Adobe.
index e37f5320e6d8adc96b4b7c4021396d2c660fe8fe..713223a63816886bef6d55311bce4dca74e6a19e 100755 (executable)
@@ -30,21 +30,19 @@ BUILD=${BUILD:-1}
 TAG=${TAG:-fsleg}
 PKGTYPE=${PKGTYPE:-txz}
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
-    i?86) ARCH=i486 ;;
+    i?86) ARCH=i586 ;;
     arm*) ARCH=arm ;;
-    # Unless $ARCH is already set, use uname -m for all other archs:
        *) ARCH=$( uname -m ) ;;
   esac
 fi
 
-if [ "i486" == "${ARCH}" ]; then
+if [ "x86_64" != "${ARCH}" ]; then
   echo
   echo "*************************************************************"
-  echo "It seems you are running a 32bit system. Standalone"
-  echo "flashplayer only supports 64bit."
+  echo "It seems you are not running a x86_64 system. Standalone"
+  echo "flashplayer only supports x86_64 architecture."
   echo "*************************************************************"
   echo
   exit 1
@@ -64,7 +62,7 @@ OUTPUT=${OUTPUT:-/tmp}
 
 # saflashplayer is a standalone static binary, so no compilation is needed
 
-set -e # Exit on most errors
+set -e
 
 rm -rf $PKG
 mkdir -p $TMP $PKG $OUTPUT
@@ -72,8 +70,7 @@ cd $TMP
 
 tar xvf $CWD/flash_player_sa_linux.x86_64.tar.gz
 mkdir -p $PKG/usr/bin $PKG/usr/share/applications
-mv flashplayer $PKG/usr/bin/saflashplayer.bin
-cp -a $CWD/saflashplayer.sh $PKG/usr/bin/saflashplayer
+mv flashplayer $PKG/usr/bin/saflashplayer
 cp -a $CWD/saflashplayer.desktop $PKG/usr/share/applications/com.adobe.flashplayer.desktop
 chown -R root:root $PKG
 find -L $PKG \
@@ -84,14 +81,12 @@ find -L $PKG \
 
 # Stripping the binary causes it to segfault
 
-# Copy program documentation into the package
 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
 cp -aR LGPL license.pdf $PKG/usr/doc/$PRGNAM-$VERSION/
 cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
 
-# Copy the slack-desc (and a custom doinst.sh if necessary) into ./install
 mkdir -p $PKG/install
 cat $CWD/slack-desc > $PKG/install/slack-desc
 
 cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/saflashplayer/saflashplayer.sh b/saflashplayer/saflashplayer.sh
deleted file mode 100755 (executable)
index e73bbda..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-/usr/bin/saflashplayer.bin "$@"
index 1399d26c134b78022ed10998f6e51ede9ce2ce5c..a8eb5e14c2953898dfab928d2f1ccac4d92bf284 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
              |-----handy-ruler------------------------------------------------------|
 saflashplayer: saflashplayer (Stand-Alone Flash Player)
 saflashplayer:
@@ -9,3 +16,4 @@ saflashplayer:
 saflashplayer: Website: https://get.adobe.com/flashplayer
 saflashplayer:
 saflashplayer:
+saflashplayer:
index f5f2fc56c6438447786aefc02d49a60523c3f9fe..75044673112268cb3718034c602ba4fead5fe99e 100755 (executable)
@@ -30,7 +30,6 @@ BUILD=${BUILD:-1}
 TAG=${TAG:-fsleg}
 PKGTYPE=${PKGTYPE:-txz}
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
     i?86) ARCH=i586 ;;
@@ -65,7 +64,7 @@ else
   LIBDIRSUFFIX=""
 fi
 
-set -e # Exit on most errors
+set -e
 
 rm -rf $PKG
 mkdir -p $TMP $PKG $OUTPUT
@@ -118,4 +117,4 @@ mkdir -p $PKG/install
 cat $CWD/slack-desc > $PKG/install/slack-desc
 
 cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
index fe14fd91ac9d8cea691ef6924a84f44c6682b299..ad198fca7cc9fbcb1dc25a8c2d661a0dd9952f1d 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
                 |-----handy-ruler------------------------------------------------------|
 shadowsocks-rust: shadowsocks-rust (rust port of shadowsocks, a secure socks5 proxy)
 shadowsocks-rust:
@@ -9,4 +16,4 @@ shadowsocks-rust: Homepage: https://github.com/shadowsocks/shadowsocks-rust
 shadowsocks-rust:
 shadowsocks-rust:
 shadowsocks-rust:
-shadowsocks-rust:
\ No newline at end of file
+shadowsocks-rust:
index 25d28f956ba59354649ba8954d5f243777e67aa3..aa3d6f215c481bbc87bfda25e6b3154bcfa9435f 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
                   |-----handy-ruler------------------------------------------------------|
 yubikey-manager-qt: yubikey-manager-qt (Graphical application for configuring a YubiKey)
 yubikey-manager-qt:
index ea129d9e16c8372423ed62ab6de7a89148e0ee7a..04513544825aeb7dd8608da93bd340c49fe226e8 100755 (executable)
@@ -35,12 +35,10 @@ if [ -z "$NUMJOBS" ]; then
   NUMJOBS=$(nproc)
 fi
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
     i?86) ARCH=i586 ;;
     arm*) ARCH=arm ;;
-    # Unless $ARCH is already set, use uname -m for all other archs:
        *) ARCH=$( uname -m ) ;;
   esac
 fi
@@ -59,22 +57,17 @@ OUTPUT=${OUTPUT:-/tmp}
 
 if [ "$ARCH" = "i586" ]; then
   SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-  LIBDIRSUFFIX=""
 elif [ "$ARCH" = "i686" ]; then
   SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-  LIBDIRSUFFIX=""
 elif [ "$ARCH" = "x86_64" ]; then
   SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
 elif [ "$ARCH" = "aarch64" ]; then
   SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
 else
   SLKCFLAGS="-O2"
-  LIBDIRSUFFIX=""
 fi
 
-set -e # Exit on most errors
+set -e
 
 rm -rf $PKG
 mkdir -p $TMP $PKG $OUTPUT
@@ -107,8 +100,6 @@ cp -a resources/com.yubico.yubikey_manager.metainfo.xml $PKG/usr/share/metainfo/
 mkdir -p $PKG/usr/share/applications
 cp -a resources/ykman-gui.desktop $PKG/usr/share/applications
 
-# Copy program documentation into the package
-# Also, include the SlackBuild script in the documentation directory
 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
 cp -a \
   COPYING NEWS README \
index 5a2c73115aafbe4794ca4be5122c34ae2b826454..e5905e49bf89f38f7c0671169db7dfc5b651ba23 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
                |-----handy-ruler------------------------------------------------------|
 yubikey-manager: yubikey-manager (Tool for managing your YubiKey configuration)
 yubikey-manager:
index 82eb03e5d391a4861ae519c23338794c6c401b67..f288dcc29cbd55f3690aee9665f6c518b74f26f8 100755 (executable)
@@ -31,12 +31,10 @@ BUILD=${BUILD:-1}
 TAG=${TAG:-fsleg}
 PKGTYPE=${PKGTYPE:-txz}
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
     i?86) ARCH=i586 ;;
     arm*) ARCH=arm ;;
-# Unless $ARCH is already set, use uname -m for all other archs:
        *) ARCH=$( uname -m ) ;;
   esac
 fi
@@ -53,23 +51,6 @@ TMP=${TMP:-/tmp/SBo}
 PKG=$TMP/package-$PRGNAM
 OUTPUT=${OUTPUT:-/tmp}
 
-if [ "$ARCH" = "i586" ]; then
-  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
-  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
-  SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "aarch64" ]; then
-  SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
-else
-  SLKCFLAGS="-O2"
-  LIBDIRSUFFIX=""
-fi
-
 set -e
 
 rm -rf $PKG
@@ -97,7 +78,6 @@ cp -aR man $PKG/usr/
 find $PKG/usr/man -type f -exec gzip -9 {} \;
 for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
 
-# Copy program documentation into the package
 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
 cp -a \
   COPYING NEWS README.adoc \
index 84f906034eeae8b9120d9d7ee4eceeab6c7926cf..f92dc24f106a21c5465ecab39b511c09bad4deae 100644 (file)
@@ -1,3 +1,10 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
                 |-----handy-ruler------------------------------------------------------|
 yubioath-desktop: yubioath-desktop (Yubico Authenticator for Desktop)
 yubioath-desktop:
@@ -9,3 +16,4 @@ yubioath-desktop:
 yubioath-desktop:
 yubioath-desktop:
 yubioath-desktop:
+yubioath-desktop:
index c2b0412dc57a43378a2369976348b26edbb6bebb..e5d4e29ed44d2b2ffd8686c50425938096e43597 100755 (executable)
@@ -31,12 +31,10 @@ BUILD=${BUILD:-1}
 TAG=${TAG:-fsleg}
 PKGTYPE=${PKGTYPE:-txz}
 
-# Automatically determine the architecture we're building on:
 if [ -z "$ARCH" ]; then
   case "$( uname -m )" in
     i?86) ARCH="ia32" ;;
     x86_64*) ARCH="x64" ;;
-    # Unless $ARCH is already set, use uname -m for all other archs:
        *) ARCH=$( uname -m ) ;;
   esac
 fi
@@ -55,7 +53,7 @@ OUTPUT=${OUTPUT:-/tmp}
 
 # This is just a repackaging of a pre-built binary, no compilation is needed
 
-set -e # Exit on most errors
+set -e
 
 rm -rf $PKG
 mkdir -p $TMP $PKG $OUTPUT
@@ -94,4 +92,4 @@ mkdir -p $PKG/install
 cat $CWD/slack-desc > $PKG/install/slack-desc
 
 cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE