]> git.t-rg.ws Git - slackbuilds.git/commitdiff
mintstick: removed. Heavily depends on GNOME now, can't patch
authorfsLeg <fsleg@t-rg.ws>
Sun, 6 Feb 2022 17:29:09 +0000 (20:29 +0300)
committerfsLeg <fsleg@t-rg.ws>
Sun, 6 Feb 2022 17:29:09 +0000 (20:29 +0300)
mintstick/README [deleted file]
mintstick/mintstick.SlackBuild [deleted file]
mintstick/mintstick.info [deleted file]
mintstick/slack-desc [deleted file]
pyparted/README [deleted file]
pyparted/pyparted.SlackBuild [deleted file]
pyparted/pyparted.info [deleted file]
pyparted/slack-desc [deleted file]

diff --git a/mintstick/README b/mintstick/README
deleted file mode 100644 (file)
index be819f5..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-Mintstick is a graphical application to write .img and .iso files to
-USB keys. It can also format USB Key from a contextual menu in
-Cinammon and KDE desktops.
\ No newline at end of file
diff --git a/mintstick/mintstick.SlackBuild b/mintstick/mintstick.SlackBuild
deleted file mode 100755 (executable)
index 7afca6e..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for mintstick
-
-# Copyright 2014-2015 Vladislav Borisov Moscow, Russia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-#    notice, this list of conditions and the following disclaimer.
-#
-#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
-#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=mintstick
-VERSION=${VERSION:-1.2.8}
-VERSION_HASH=${VERSION_HASH:-ce797e4af9ab9524daef4b5642e1e0cdfb57b57b}
-BUILD=${BUILD:-1}
-TAG=${TAG:-fsleg}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
-  case "$( uname -m )" in
-    i?86) ARCH=i486 ;;
-    arm*) ARCH=arm ;;
-    # Unless $ARCH is already set, use uname -m for all other archs:
-       *) ARCH=$( uname -m ) ;;
-  esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "x86_64" ]; then
-  LIBDIRSUFFIX="64"
-else
-  LIBDIRSUFFIX=""
-fi
-
-set -e # Exit on most errors
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-
-rm -rf $PRGNAM-$VERSION_HASH
-unzip $CWD/$VERSION_HASH.zip
-cd $PRGNAM-$VERSION_HASH
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-  -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# mintstick is just a few python scripts, so there's nothing to build
-# The following is taken from install.sh
-LIBFILES="mintstick.py raw_write.py raw_format.py mountutils.py"
-DATAFILES="mintstick.ui"
-
-mkdir -p ${PKG}/usr/share/applications
-mkdir -p ${PKG}/usr/bin
-mkdir -p ${PKG}/usr/share/polkit-1/actions
-mkdir -p ${PKG}/usr/share/kde4/apps/solid/actions
-cp share/applications/mintstick.desktop ${PKG}/usr/share/applications/
-cp share/applications/mintstick-format.desktop ${PKG}/usr/share/applications/
-cp share/applications/mintstick-kde.desktop ${PKG}/usr/share/applications/
-cp share/applications/mintstick-format-kde.desktop ${PKG}/usr/share/applications/
-cp share/polkit/org.linuxmint.im.policy ${PKG}/usr/share/polkit-1/actions
-cp share/kde4/mintstick-format_action.desktop ${PKG}/usr/share/kde4/apps/solid/actions
-cp mintstick ${PKG}/usr/bin/
-mkdir -p ${PKG}/usr/lib${LIBDIRSUFFIX}/mintstick
-mkdir -p ${PKG}/usr/share/mintstick
-
-for item in $LIBFILES; do
-    cp lib/$item ${PKG}/usr/lib${LIBDIRSUFFIX}/mintstick/
-done
-
-for item in $DATAFILES; do
-    cp share/mintstick/$item ${PKG}/usr/share/mintstick/
-done
-
-# Fix library dir for x86_64
-sed -i "s,/usr/lib/,/usr/lib${LIBDIRSUFFIX}/," ${PKG}/usr/bin/mintstick \
-                                               ${PKG}/usr/lib${LIBDIRSUFFIX}/mintstick/mintstick.py
-
-# Copy a parody to the man page
-mkdir -p ${PKG}/usr/man/man1
-cp debian/mintstick.1 ${PKG}/usr/man/man1/
-
-# Compress man pages
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-# Copy program documentation into the package
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -aR \
-  debian/{changelog,copyright} \
-  COPYING README TODO \
-  $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Copy the slack-desc into ./install
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-noarch-$BUILD$TAG.${PKGTYPE:-txz}
diff --git a/mintstick/mintstick.info b/mintstick/mintstick.info
deleted file mode 100644 (file)
index 74509a3..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mintstick"
-VERSION="1.2.8"
-HOMEPAGE="https://github.com/linuxmint/mintstick/"
-DOWNLOAD="https://github.com/linuxmint/mintstick/archive/ce797e4af9ab9524daef4b5642e1e0cdfb57b57b.zip"
-MD5SUM=""
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pyparted pygobject3"
-MAINTAINER="Vladislav Borisov"
-EMAIL="fsleg@t-rg.ws"
diff --git a/mintstick/slack-desc b/mintstick/slack-desc
deleted file mode 100644 (file)
index d9c633d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-         |-----handy-ruler------------------------------------------------------|
-mintstick: mintstick (USB stick formatter)
-mintstick:
-mintstick: Mintstick is a graphical application to write .img and .iso files to
-mintstick: USB keys. It can also format USB Key from a contextual menu in
-mintstick: Cinammon and KDE desktops.
-mintstick:
-mintstick: Website: https://github.com/linuxmint/mintstick
-mintstick:
-mintstick:
-mintstick:
diff --git a/pyparted/README b/pyparted/README
deleted file mode 100644 (file)
index 13a16dd..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-pyparted is a set of Python modules that provide Python programmers an interface 
-to libparted, the ​GNU parted library fordisk partitioning and filesystem 
-manipulation.
diff --git a/pyparted/pyparted.SlackBuild b/pyparted/pyparted.SlackBuild
deleted file mode 100755 (executable)
index f14187b..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyparted
-
-# Copyright 2014 Vladislav Borisov Moscow, Russia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-#    notice, this list of conditions and the following disclaimer.
-#
-#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
-#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pyparted
-VERSION=${VERSION:-3.10.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-fsleg}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
-  case "$( uname -m )" in
-    i?86) ARCH=i486 ;;
-    arm*) ARCH=arm ;;
-    # Unless $ARCH is already set, use uname -m for all other archs:
-       *) ARCH=$( uname -m ) ;;
-  esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
-  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
-  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-  LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
-  SLKCFLAGS="-O2 -fPIC"
-  LIBDIRSUFFIX="64"
-else
-  SLKCFLAGS="-O2"
-  LIBDIRSUFFIX=""
-fi
-
-set -e # Exit on most errors
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-  -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build
-python setup.py install --root=$PKG -c -O1
-
-# Strip binaries and libraries
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
-  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Copy program documentation into the package
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
-  AUTHORS BUGS ChangeLog COPYING HACKING NEWS PKG-INFO README RELEASE TODO \
-  $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Copy the slack-desc (and a custom doinst.sh if necessary) into ./install
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
diff --git a/pyparted/pyparted.info b/pyparted/pyparted.info
deleted file mode 100644 (file)
index bb1c55c..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyparted"
-VERSION="3.10.0"
-HOMEPAGE="https://fedorahosted.org/pyparted/"
-DOWNLOAD="https://fedorahosted.org/releases/p/y/pyparted/pyparted-${VERSION}.tar.gz"
-MD5SUM="a07185bbf7aaf63d5214fcbcc832781e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Vladislav Borisov"
-EMAIL="fsleg@t-rg.ws"
diff --git a/pyparted/slack-desc b/pyparted/slack-desc
deleted file mode 100644 (file)
index 50f1ae6..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-        |-----handy-ruler------------------------------------------------------|
-pyparted: pyparted (python bindings for parted)
-pyparted:
-pyparted: pyparted is a set of Python modules that provide Python programmers
-pyparted: an interface to libparted, the ​GNU parted library fordisk 
-pyparted: partitioning and filesystem manipulation.
-pyparted:
-pyparted: Website: https://fedorahosted.org/pyparted/
-pyparted:
-pyparted:
-pyparted: