]> git.t-rg.ws Git - slackbuilds.git/commitdiff
pyscard: added
authorfsLeg <fsleg@t-rg.ws>
Sun, 4 Jun 2023 14:14:45 +0000 (17:14 +0300)
committerfsLeg <fsleg@t-rg.ws>
Sun, 4 Jun 2023 14:14:45 +0000 (17:14 +0300)
pyscard/README [new file with mode: 0644]
pyscard/pyscard.SlackBuild [new file with mode: 0755]
pyscard/pyscard.info [new file with mode: 0644]
pyscard/slack-desc [new file with mode: 0644]

diff --git a/pyscard/README b/pyscard/README
new file mode 100644 (file)
index 0000000..bc0b374
--- /dev/null
@@ -0,0 +1,4 @@
+pyscard - Python smart card library - is a Python module adding smart
+cards support to Python.
+
+To build HTML documentation use DOCS=yes. This requires Sphinx.
diff --git a/pyscard/pyscard.SlackBuild b/pyscard/pyscard.SlackBuild
new file mode 100755 (executable)
index 0000000..633ce59
--- /dev/null
@@ -0,0 +1,107 @@
+#!/bin/bash
+
+# Slackware build script for pyscard
+
+# Copyright 2023 Vladislav Borisov, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
+#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=pyscard
+VERSION=${VERSION:-2.0.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-fsleg}
+PKGTYPE=${PKGTYPE:-txz}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i586 ;;
+    arm*) ARCH=arm ;;
+# Unless $ARCH is already set, use uname -m for all other archs:
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+else
+  SLKCFLAGS="-O2"
+  LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+  -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+# Strip binaries and libraries.
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Copy program documentation into the package
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+
+# Build additional documentation
+if [ "${DOCS:-no}" != "no" ]; then
+  cd smartcard/doc
+  make html
+  cp -aR _build/html $PKG/usr/doc/$PRGNAM-$VERSION/
+  cd ../..
+fi
+
+cp -aR \
+  ACKS ChangeLog LICENSE TODO README.md smartcard/Examples \
+  $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Copy the slack-desc into ./install
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Make the package
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/pyscard/pyscard.info b/pyscard/pyscard.info
new file mode 100644 (file)
index 0000000..f2e2db4
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="pyscard"
+VERSION="2.0.7"
+HOMEPAGE="https://pyscard.sourceforge.io/"
+DOWNLOAD="https://github.com/LudovicRousseau/pyscard/archive/refs/tags/2.0.7.tar.gz"
+MD5SUM="5317ccb33ec5e56a025f814f606e4c16"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pcsc-lite"
+MAINTAINER="Vladislav Borisov"
+EMAIL="fsleg@t-rg.ws"
diff --git a/pyscard/slack-desc b/pyscard/slack-desc
new file mode 100644 (file)
index 0000000..d79d44a
--- /dev/null
@@ -0,0 +1,12 @@
+       |-----handy-ruler------------------------------------------------------|
+pyscard: pyscard (Smartcard module for Python)
+pyscard:
+pyscard: pyscard - python smart card library - is a python module adding smart
+pyscard: cards support to python.
+pyscard:
+pyscard: Website: https://pyscard.sourceforge.io/
+pyscard:
+pyscard:
+pyscard:
+pyscard:
+pyscard: