]> git.t-rg.ws Git - slackbuilds.git/commitdiff
yubico-piv-tool: added
authorfsLeg <fsleg@t-rg.ws>
Sun, 28 May 2023 17:25:33 +0000 (20:25 +0300)
committerfsLeg <fsleg@t-rg.ws>
Sun, 28 May 2023 17:25:33 +0000 (20:25 +0300)
yubico-piv-tool/README [new file with mode: 0644]
yubico-piv-tool/slack-desc [new file with mode: 0644]
yubico-piv-tool/yubico-piv-tool.SlackBuild [new file with mode: 0755]
yubico-piv-tool/yubico-piv-tool.info [new file with mode: 0644]

diff --git a/yubico-piv-tool/README b/yubico-piv-tool/README
new file mode 100644 (file)
index 0000000..ad106e2
--- /dev/null
@@ -0,0 +1,6 @@
+The Yubico PIV tool is used for interacting with the Personal Identity
+Verification (PIV) application on a YubiKey.
+
+With it you may generate keys on the device, importing keys and
+certificates, and create certificate requests, and other operations.
+A shared library and a command-line tool is included.
diff --git a/yubico-piv-tool/slack-desc b/yubico-piv-tool/slack-desc
new file mode 100644 (file)
index 0000000..d9657f2
--- /dev/null
@@ -0,0 +1,12 @@
+               |-----handy-ruler------------------------------------------------------|
+yubico-piv-tool: yubico-piv-tool (command line tool for the YubiKey PIV application)
+yubico-piv-tool:
+yubico-piv-tool: The Yubico PIV tool is used for interacting with the Personal
+yubico-piv-tool: Identity Verification (PIV) application on a YubiKey.
+yubico-piv-tool:
+yubico-piv-tool: With it you may generate keys on the device, importing keys and
+yubico-piv-tool: certificates, and create certificate requests, and other operations.
+yubico-piv-tool: A shared library and a command-line tool is included.
+yubico-piv-tool:
+yubico-piv-tool: https://developers.yubico.com/yubico-piv-tool/
+yubico-piv-tool:
diff --git a/yubico-piv-tool/yubico-piv-tool.SlackBuild b/yubico-piv-tool/yubico-piv-tool.SlackBuild
new file mode 100755 (executable)
index 0000000..0bd8df5
--- /dev/null
@@ -0,0 +1,118 @@
+#!/bin/sh
+
+# Slackware build script for yubico-piv-tool
+
+# Copyright 2023 Vladislav Borisov Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
+#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=yubico-piv-tool
+VERSION=${VERSION:-2.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-fsleg}
+PKGTYPE=${PKGTYPE:-txz}
+
+# Use parallel building if possible
+if [ -z "$NUMJOBS" ]; then
+  NUMJOBS=$(nproc)
+fi
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i586 ;;
+    arm*) ARCH=arm ;;
+# Unless $ARCH is already set, use uname -m for all other archs:
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+else
+  SLKCFLAGS="-O2"
+  LIBDIRSUFFIX=""
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+  -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+  cmake \
+    -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+    -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DYKPIV_INSTALL_MAN_DIR=/usr/man \
+    -DCMAKE_BUILD_TYPE=Release ..
+  make -j${NUMJOBS}
+  make DESTDIR=$PKG install
+cd ..
+
+# Strip binaries and libraries
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Compress man pages
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+# Copy program documentation into the package
+# Also, include the SlackBuild script in the documentation directory
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -aR \
+  COPYING NEWS README debian/changelog doc/*.adoc doc/Actions/ doc/YKCS11/ \
+  $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Copy the slack-desc into ./install
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Make the package
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/yubico-piv-tool/yubico-piv-tool.info b/yubico-piv-tool/yubico-piv-tool.info
new file mode 100644 (file)
index 0000000..504ea11
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="yubico-piv-tool"
+VERSION="2.3.1"
+HOMEPAGE="https://developers.yubico.com/yubico-piv-tool/"
+DOWNLOAD="https://developers.yubico.com/yubico-piv-tool/Releases/yubico-piv-tool-2.3.1.tar.gz"
+MD5SUM="521cf9352b562a2d3946a359de7faf20"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gengetopt pcsc-lite"
+MAINTAINER="Vladislav Borisov"
+EMAIL="fsleg@t-rg.ws"